This latest lab requires just a few commands on two neighboring routers to get a serial link working. Configure PPP, IPv4 addresses, and get the link up and working with the Telco serial link. Check the original requirements first, create your answer, and check back here to compare your answer with ours.

 

Answers

Figure 1: Two Routers with IP Subnets

Example 1: R1 Config

interface Serial0/0
 no shutdown
 encapsulation ppp
 ip address 10.20.30.193 255.255.255.192
 bandwidth 768

Example 2: R2 Config

interface Serial0/0
 no shutdown
 encapsulation ppp
 ip address 10.20.30.194 255.255.255.192
 bandwidth 768

 

Commentary

Most serial interfaces on Cisco devices support a number of different encapsulation types including the three most common: HDLC, Point-to-Point Protocol (PPP), and Frame Relay. This lab asks for PPP, requiring then the encapsulation ppp command on both routers’ serial interfaces.

For a link created by the Telco, the Telco provides clocking. The routers need a clock rate interface subcommand only if creating a serial link with back-to-back serial cables in a lab. So, your config should not include a clock rate command.

The Telco clocks the link at 768 Kbps in this case, so both routers’ serial interfaces need a bandwidth 768 command, which means 768 kbps.

Finally, each router’s serial interface needs to have its IP address set (ip address), and the interface must be enabled (no shutdown).